Skip to content

Docker image: bump Node to 24.22.1 (CVE-2026-111497) #6927

Open

Description

@mahfuz-rahman007

I run the official v2.16.1 image, and the Node.js it ships is 18.20.8. That build is affected by CVE-2026-111497, a vulnerability in Node's Brotli decoder that can lead to remote code execution, fixed on 21 October 2026 in Node 22.23.4, 24.22.1, and 26.12.1 (https://nodejs.org/en/blog/vulnerability). Node 14, 16, 18, 19, 20, 21, 23, and 25 are end of life and will not get this patch, so the runtime needs to be on 22.23.4, 24.22.1, or 26.12.1. In Dockerfile, the image is still based on node:18-alpine. Updating that to node:24.22.1-alpine and publishing a new release would ship a patched runtime. The patch below is only that version bump. Happy to adjust the suffix if you prefer another patched line (22.23.4, 24.22.1, or 26.12.1).

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions