pgloader version "3.6.9"
compiled with SBCL 2.3.8
No.
Yes.
Load file with:
LOAD DATABASE
FROM mysql://<connection string>
INTO postgresql://<connection string>
WITH data only, truncate, disable triggers, downcase identifiers, reset sequences,
workers = 8, concurrency = 1, prefetch rows = 500, batch rows = 500,
single reader per thread, on error stop
2024-06-26T12:12:52.888381-04:00 LOG report summary reset
table name errors read imported bytes total time read write
--------------------------------------------------- --------- --------- --------- --------- -------------- --------- ---------
fetch meta data 0 109 109 0.201s
Drop Foreign Keys 0 0 0 0.000s
Truncate 0 53 53 0.255s
--------------------------------------------------- --------- --------- --------- --------- -------------- --------- ---------
I see it indicated 'Truncate' , but I suspect table is not being truncated as subsequently the COPY fails with 'Duplicate Primary key constraint violation'.
After the run I still see the old rows in the table.
I am looking to migrate data only, the script failed, on re-running was expecting it to 'detect there is data in the target table on postgres and expecting it to truncate the table prior to running the COPY of the data.
Is there a way to DUMP/Log the SQL pgloader runs for 'truncate'? so I can verify the '53 truncates' it indicates above?
No.
Yes.
Load file with:
I see it indicated 'Truncate' , but I suspect table is not being truncated as subsequently the COPY fails with 'Duplicate Primary key constraint violation'.
After the run I still see the old rows in the table.
I am looking to migrate data only, the script failed, on re-running was expecting it to 'detect there is data in the target table on postgres and expecting it to truncate the table prior to running the COPY of the data.
Is there a way to DUMP/Log the SQL pgloader runs for 'truncate'? so I can verify the '53 truncates' it indicates above?